Jump to content
TeardownMods

8 Screenshots

About This File

STEAM WORKSHOP IS HERE!!! YOU CAN SUBSCRIBE TO ALL MY WEAPONS HERE:
https://steamcommunity.com/sharedfiles/filedetails/?id=2401926535

ADDED TWO NEW WEAPONS, M1 GARAND AND HOOK SHOTGUN!
THE WEAPONS ALSO HAVE ALOT MORE ANIMATIONS AND TWEAKS.

 

The Vox Models are made by:
- @Alagabry: AK, AWP, NOVA, M249, M4
- @cCheerSs: RPG, Laser Cutter, Mjölner
- @Kolaach: MGL
- @Cheejins: AC130 Plane
- @landenbullard : P90

- @MyCresta: Desert Eagle, Berettas, SG553, SCAR-20, Minigun, Hadouken, Scorpion, Dragonslayer, Charge Shotgun, Dual Miniguns, Holy Grenade, .500 Magnum, Magic Bag
 

Edited by MyCresta
Updated description


What's New in Version 4.0.0

Released

STEAM WORKSHOP IS HERE

  • Like 12
  • Thanks 2

User Feedback

Recommended Comments



59 minutes ago, take lol said:

do i have to put the zip or all the weapon folders at once in the mods folder

Pu each weapon folder separately in the mods folder, like any other mods you installed there, that way you can enable/disable each weapon how you want in the modloader in main menu.

Link to comment
Share on other sites
26 minutes ago, MyCresta said:

Pu each weapon folder separately in the mods folder, like any other mods you installed there, that way you can enable/disable each weapon how you want in the modloader in main menu.

is it normal that the mod is just working like a recoller for guns becous when i activate the mods and im in the game these are just recoller

Link to comment
Share on other sites

I have TD 5.1 as of today.  I also have UMF 5.0.  When I follow instructions placing your weapon folders in documents->teardown->mods, then run modloader.bat, the gun don't load properly.  To fix this I just placed the weapons folders inside "Program Files (x86)\Steam\steamapps\common\Teardown\mods" folder and ran the modloader and it worked great!  Not sure why it didn't work with the normal 5.0 mod installation, but if anyone else runs into the issue, this fixed it.  Great guns, great work!

Link to comment
Share on other sites
1 minute ago, take lol said:

is it normal that the mod is just working like a recoller for guns becous when i activate the mods and im in the game these are just recoller

What do you mean by recoller?
 

2 minutes ago, karmikovic said:

I have TD 5.1 as of today.  I also have UMF 5.0.  When I follow instructions placing your weapon folders in documents->teardown->mods, then run modloader.bat, the gun don't load properly.  To fix this I just placed the weapons folders inside "Program Files (x86)\Steam\steamapps\common\Teardown\mods" folder and ran the modloader and it worked great!  Not sure why it didn't work with the normal 5.0 mod installation, but if anyone else runs into the issue, this fixed it.  Great guns, great work!

hmm, that is strange, i wonder if there are some special conditions which makes it not work properly, it's been working like usual for me and others who tried it so far.
I guess you already downloaded the latest version of UMF also? there are some changes there from 0.5.0 to 0.5.1, otherwise i don't really know what the reason for this is.

Link to comment
Share on other sites

No problem, I just posted a workaround in case others have the same problem.  I have the UMF branch for 0.5.0 and TD 5.1.  Excellent job.  Loved the Laser, GL and RPG the best

  • Like 1
Link to comment
Share on other sites

I think take lol meant recolor.  He probably was experiencing the same issue with just the skin being mapped over but no sound changes or bullet impacts.  Hopefully he can use the posted fix above to get to experience your mod. 🙂

Link to comment
Share on other sites
Just now, take lol said:

now the weapons are down listed in game but i cant shoot with them

Are you on the latest experimental branch? and you downloaded the latest UMF? Do you see a console in the main menu?

Link to comment
Share on other sites

MyCresta yes i see a console and i downloaded the latset version and karmikovic i tried and they loaded but i cant equip them in the UMP and in the normal mode they dont shoot

Link to comment
Share on other sites

hello, as previously stated I have td 0.5.1 and umd downloaded and I'm pretty sure I followed the steps correctly but i cant use all the guns only one at a time and they're just a reskin of the gun, they don't do anything different other then looking like different weapons, pls help..

Link to comment
Share on other sites
3 minutes ago, penut butterejellytyme said:

hello, as previously stated I have td 0.5.1 and umd downloaded and I'm pretty sure I followed the steps correctly but i cant use all the guns only one at a time and they're just a reskin of the gun, they don't do anything different other then looking like different weapons, pls help..

Are you sure you picked the right version of the UMF aswell? There is a main branch, which is the wrong one, and then theres the exp UMF 0.5.0.

Otherwise, could you show me a print of the console ingame if there are any errors there.

Link to comment
Share on other sites
1 minute ago, penut butterejellytyme said:

im sure i got the latest version, i followed the steps, how do i open the console?

If you don't see any console in the main menu when you start the game, you have done something wrong while installing the UMF.
I recommend you remove the "umf" folder inside the steam game install folder Teardown/mods/
Then reinstall the umf following this 

Link to comment
Share on other sites
2 hours ago, MyCresta said:

If you don't see any console in the main menu when you start the game, you have done something wrong while installing the UMF.
I recommend you remove the "umf" folder inside the steam game install folder Teardown/mods/
Then reinstall the umf following this 

looool i figured out what i did wrong, i opened the hook file in the .zip then moved it to the teardown folder, its working now thanks!

Link to comment
Share on other sites

I am trying to get the laser cutter mod to work, but I am having the issue where it is loading the thief gun skin, but it still shoots like the default gun. I believe I have followed all of the instructions correctly. I updated to the experimental version of teardown, installed the latest version of UMF and ran the hook file, I put the weapon folder in Documents/Teardown/mods, and I am able to enable it in the mod loader. But then when I load the game, the gun doesn't work right. I read through the comments and I don't see where anyone else is having a similar issue. 

Link to comment
Share on other sites
9 minutes ago, Zander128 said:

I am trying to get the laser cutter mod to work, but I am having the issue where it is loading the thief gun skin, but it still shoots like the default gun. I believe I have followed all of the instructions correctly. I updated to the experimental version of teardown, installed the latest version of UMF and ran the hook file, I put the weapon folder in Documents/Teardown/mods, and I am able to enable it in the mod loader. But then when I load the game, the gun doesn't work right. I read through the comments and I don't see where anyone else is having a similar issue. 

Hey, thank you for providing me with some good information to work on 🙂

This is a new one for me, i think it is probably something with UMF. You are not seeing "LASER CUTTER" among the tools in the bottom tool bar when scrolling? like this:
image.thumb.png.f3c5a85700a5b02759ba83870be82f07.png

If not, i assume something went wrong while installing UMF, do you have this in built-in column?

image.png.9034e89925aeb9ce4389e0c632e32238.png

I can't think of anything other than that, best way is probably to reinstall and make sure to reset files.
Because there is no way that the folders in document folder can be incorrect in this case, unless you placed folders wrong.
It should look like this:
image.png.3133d88da04455f63b39086e38756302.png

I would go into steam install folder Teardown/mods, remove the folder "umf", and make sure you don't have any old UMF folders there, like "core" and "framework".
Open steam > library > Teardown > Properties > Local Files > Verify integrity
Redownload https://github.com/Thomasims/TeardownUMF master branch
Readd the files to teardown install folder, run hook_modloader and then try if it works

Link to comment
Share on other sites
1 hour ago, MyCresta said:

Hey, thank you for providing me with some good information to work on 🙂

This is a new one for me, i think it is probably something with UMF. You are not seeing "LASER CUTTER" among the tools in the bottom tool bar when scrolling? like this:
image.thumb.png.f3c5a85700a5b02759ba83870be82f07.png

If not, i assume something went wrong while installing UMF, do you have this in built-in column?

image.png.9034e89925aeb9ce4389e0c632e32238.png

I can't think of anything other than that, best way is probably to reinstall and make sure to reset files.
Because there is no way that the folders in document folder can be incorrect in this case, unless you placed folders wrong.
It should look like this:
image.png.3133d88da04455f63b39086e38756302.png

I would go into steam install folder Teardown/mods, remove the folder "umf", and make sure you don't have any old UMF folders there, like "core" and "framework".
Open steam > library > Teardown > Properties > Local Files > Verify integrity
Redownload https://github.com/Thomasims/TeardownUMF master branch
Readd the files to teardown install folder, run hook_modloader and then try if it works

I guess it was working all along, but I was only using the numbers to select weapons instead of scrolling, so that is why I couldn't use it. Silly mistake on my part. Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

How to Disable AdBlock - And why you should do it?

I have disabled AdBlocker. Refresh the page.